Animate Blood Cells in Blender
<table>
<thead>
<tr>
<th>Edit Shortcuts</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Shift + S</td>
<td>snap</td>
<td></td>
</tr>
<tr>
<td>X or delete button</td>
<td>delete</td>
<td></td>
</tr>
<tr>
<td>TAB</td>
<td>toggle edit/object mode</td>
<td>In edit mode</td>
</tr>
<tr>
<td>E</td>
<td>extrude</td>
<td></td>
</tr>
<tr>
<td>Ctrl + TAB</td>
<td>choose component</td>
<td></td>
</tr>
<tr>
<td>K</td>
<td>knife</td>
<td></td>
</tr>
<tr>
<td>F</td>
<td>add face</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Navigate Shortcuts</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Shift + hold MM wheel</td>
<td>pan</td>
<td></td>
</tr>
<tr>
<td>Hold MM wheel</td>
<td>tumble</td>
<td></td>
</tr>
<tr>
<td>Scroll MM wheel</td>
<td>zoom</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Window Shortcuts</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>(in 3D view)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>N</td>
<td>Properties Panel</td>
<td></td>
</tr>
<tr>
<td>T</td>
<td>Tool Shelf</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Manipulate Shortcuts</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>R</td>
<td>rotate</td>
<td></td>
</tr>
<tr>
<td>S</td>
<td>scale</td>
<td></td>
</tr>
<tr>
<td>G</td>
<td>move</td>
<td></td>
</tr>
<tr>
<td>After selecting R,S or G</td>
<td></td>
<td></td>
</tr>
<tr>
<td>X</td>
<td>constrain to X</td>
<td></td>
</tr>
<tr>
<td>Y</td>
<td>constrain to Y</td>
<td></td>
</tr>
<tr>
<td>Z</td>
<td>constrain to Z</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Select Shortcuts</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>deselect</td>
<td></td>
</tr>
<tr>
<td>B</td>
<td>box marquee tool</td>
<td></td>
</tr>
<tr>
<td>Shift + RMB</td>
<td>add to selection</td>
<td></td>
</tr>
<tr>
<td>Alt + RMB</td>
<td>select loop</td>
<td></td>
</tr>
<tr>
<td>Ctrl + RMB</td>
<td>select faces between</td>
<td></td>
</tr>
<tr>
<td>Ctrl + &quot;+&quot;</td>
<td>grow selection</td>
<td></td>
</tr>
<tr>
<td>Ctrl + &quot;-&quot;</td>
<td>shrink selection</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Notes:</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**RIGHT** selects  
**LEFT** completes operation
How to use this guide

1. After getting familiar with the UI, left click near (-1.5,0,0)
2. If your 3D cursor is not quite at (-1.5,0,0) use Shift + S, "Cursor to Grid"
3. If left clicking and snapping are unreliable, press "N" to toggle the properties window within 3D view. Find the 3D cursor options and manually input coordinates.

Shortcuts Used:
- Shift + S: snap
- N: properties panel

Why:
Primitives are created at the 3D cursor. Other operations also depend upon the 3D cursor's location. You may left click anywhere to move the 3D cursor or give explicit coordinates in the properties panel "N" (not to be confused with the properties editor)
1. Create a cylinder with the above settings

**Shortcuts Used:**

**Why:**
There are many ways to model a red blood cell. The objective is to keep the number of polygons low for now.
1. Shift RMB select all of the top and bottom faces.

**Shortcuts Used:**

- Tab: toggle edit/object mode
- Ctrl+Tab: change component

**Why:**


1. Hit "E" to extrude and then hit "S" to scale.
2. Either left click to complete the scale and type in the above values or type in .5,.5,1 while still scaling.

**Shortcuts Used:**
- E ......................... extrude
- S ......................... scale

**Why:**
Right now we are adding geometry to prepare for the bevel operation.
1. **Alt + RMB** select the top edge loop and then **shift + Alt + RMB** the bottom edge loop. These edges will be beveled.

**Shortcuts Used:**

Alt+RMB.................. select loop

**Why:**

using Alt to select the entire loop saves time
1. Hit Ctrl + "B" to bevel. Use the above settings.

**Shortcuts Used:**

<table>
<thead>
<tr>
<th>Shortcuts</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl + B</td>
<td>bevel</td>
</tr>
</tbody>
</table>

**Why:**

Ctrl + B...............bevel
1. Select the triangles on top and bottom then hit "E" to extrude and "S" to scale them inward. Use settings above.

**Shortcuts Used:**
- E ............... extrude
- S ............... scale

**Why:**
1. Repeat the last step 2 more times to get the red blood cell shape.

**Shortcuts Used:**

- E .......................... extrude
- S .......................... scale

**Why:**
1. Notice that the faces still look faceted. Hit "smooth" under Tools>Shading>Smooth.

**Shortcuts Used:**

- Why:
  - This will change the face normals to give a smooth look without adding polygons.
1. Create > Mesh > Ico Sphere.

2. Note: Make sure that the 3D cursor is at the center (0,0,0). If not, use Shift + "S" to open the snapping menu and select "Cursor to Center" before adding Ico Sphere.

**Shortcuts Used:**

**Why:**

An Ico Sphere is used to make a white blood cell. Icosphere is made up of evenly distributed triangles whereas a UV sphere will have triangles meeting at the poles which will effect the final look.
1. Modifiers>Add Modifier>Subdivision Surface

**Shortcuts Used:**

**Why:**
Subdividing the mesh gives the cell more resolution which will be needed for the displacement texture.
1. **Material > New Material**

2. Set the "Emit" value to around .2. Emission will make the cell more visible

**Shortcuts Used:**

**Why:**

Living things emit light
1. Texture>Clouds
   Settings:
   Color>Contrast = 2
   Mapping>Coordinates = generated
   play with other settings
2. Switch shading mode to "Rendered"

**Shortcuts Used:**

**Why:**
The clouds texture will influence the displacement of the ico sphere geometry giving it a rough, bumpy surface
"Generated" automatically generates texture coordinates according to undeformed vertex positions
1. Click checkbox for "Displace"
   optional: select checkbox for emit and translucency

**Shortcuts Used:**

**Why:**
Multiple textures can influence different aspects of the shader. In this example we are using the same Clouds texture for multiple inputs.
1. Cloud Settings:
   Colors = uncheck "clamp"
   Clouds>Noise = "hard"
   Influence>Blend = check "negative"

Shortcuts Used: checking "negative" under Blend will invert the texture.
1. Repeat last 3 steps to create red blood cell shader

Texture Settings:

Mapping>Coordinates = "object"

**Shortcuts Used:**

**Why:**

object coordinates uses the object as a source for the coordinates
1. Create NURBS circle with radius 6 and rotation of y=90.
   Note: be sure to select "Curve Circle" and not "Mesh Circle"

2. **IMPORTANT**: click object> apply> scale and rotation.

---

**Shortcuts Used:**

Shift + A ...................... add

**Why:**

Applying scale and rotation will give the circle the same orientation as world space.
1. Create > Curve > Path

**Shortcuts Used:**

This path will be the length of the blood channel
1. Hit Tab to go into edit mode for path
2. Hit "N" to toggle on the properties tab.
3. Under Control point set the control points X position from 1-5: 0,16,32,48,64

**Shortcuts Used:**
- Tab ................... edit mode
- N ................... properties panel

**Why:**
Primitives are created at the 3D cursor. Other operations also depend upon the 3D cursor's location. You may left click anywhere to move the 3D cursor or give explicit coordinates in the properties panel "N" (not to be confused with the properties editor)
1. Hit TAB to toggle back into object mode of Path
2. Select BezierCircle as bevel path as shown above
1. Hit spacebar and type convert or use Alt + C to Convert "Mesh from Curve"
2. A mesh is needed for collision to work

**Shortcuts Used:**
Alt + C ......................... convert

**Why:**
Convert is a destructive process. After converting, no more changes can be made to the tube's path.
1. Create Mesh>Circle with 6 radius and rotation of y=90 with a triangular fan fill type
2. click object>apply>rotation & scale

**Shortcuts Used:**
Shift + A ......................... add

**Why:**
This polygon circle will be the emitter. Particles will emit from the circle. If the circle is moved, the particles will follow.
1. In properties editor click "New" under particle system tab

**Shortcuts Used:**

**Why:**

Particles must be emitted from a polygon mesh.
1. Set emission rate to 200, lifespan to 180
2. Set gravity to 0, mass to .5, and 8 for X under force field settings
3. Press play to test. Hit "z" to toggle into wireframe viewport shading

**Shortcuts Used:**
Z ...................... wireframe view

**Why:**
Remember: new objects are created at the 3D cursor's location.
1. Shift RMB select both cells and group them (Ctrl+G)

**Shortcuts Used:**

Ctrl + G ......................... group

**Why:**

Primitives are created at the 3D cursor. Other operations also depend upon the 3D cursor's location. You may left click anywhere to move the 3D cursor or give explicit coordinates in the properties panel "N" (not to be confused with the properties editor)
1. Select the emitter circle again and under particles options, set Render to "Group". Click in the field box of "Dupli Group" and select the grouped cells.

**Shortcuts Used:**

**Why:**
1. Change the count to have a realistic distribution of red and white cells. You must check the "Use Count" box to set the ratio of red and white.

**Shortcuts Used:**
- Shift + S: snap
- N: properties panel

**Why:**
Primitives are created at the 3D cursor. Other operations also depend upon the 3D cursor's location. You may left click anywhere to move the 3D cursor or give explicit coordinates in the properties panel "N" (not to be confused with the properties editor).
1. Make the above changes to "Rotation" under Particle system. Notice the change. Select the "Dynamic" checkbox and up the angular velocity to give the cells dynamic rotation.

**Shortcuts Used:**

**Why:**
Remember: new objects are created at the 3D cursor's location.
1. Hit Add>Force Field>Turbulence. Set the strength to 32.

**Shortcuts Used:**

**Why:**
Turbulence will give the cells a more natural movement. Increasing the Brownian level has a similar effect.
1. Select the gray tube and under physics tab select collision.

**Shortcuts Used:**

If the tube had not been converted to a mesh, the collision option would not be available.

**Why:**

If the tube had not been converted to a mesh, the collision option would not be available.
1. Notice collision

**Shortcuts Used:**

- It is best to use a low polygon model for collision and exclude it from rendering. Then create a high polygon detailed tube to be rendered.
1. Create a plane with the above settings. This will be the kill plane

**Shortcuts Used:**
This plane will not be rendered but serves as a stopping point for the particles. Once a particle hits the plane it will die.

**Why:**
This plane will not be rendered but serves as a stopping point for the particles. Once a particle hits the plane it will die.
1. Select checkbox for "Wire" under display and deselect the camera so the plane does not render

**Shortcuts Used:**

**Why:** Setting the display to wire is not required but will make your viewport less cluttered.
1. Under physics tab of plane, enable collision and select checkbox for "kill particles"

**Shortcuts Used:**

**Why:**
The plane is very simple: only one four sided face. The kill plane does not need to have a high polygon count.
1. Move camera to above settings and change rotation

**Shortcuts Used:**

**Why:**

We are preparing the scene for rendering. Before, we used the interactive viewport render. The final rendered images will be rendered from this camera.
1. Move and make changes to the lamp

Shortcuts Used:  

Why:
1. Duplicate the gray tube, the duplicate will be rendered and the original will serve only as a collision object.

**Shortcuts Used:**

- Shift + D ................. duplicate

**Why:**

A duplicate will be used for render. This duplicate will have a higher polygon count so we will avoid using it for collision which saves simulation time.
1. Extrude the faces and set scale as shown above
2. Hit Tab to go back into object mode and under the physics tab turn off collision on the new tube.

**Shortcuts Used:**
- Tab ............ toggle edit/object
- A ............... deselect or select all
- E ....................... extrude
- S ....................... scale

**Why:**
Leaving the scale X at 1 will insure that the tube stays the same length.
1. Create an interesting material with a voronoi texture as the displacement and/or color
**Pitfalls**

<table>
<thead>
<tr>
<th>Problem</th>
<th>Why</th>
</tr>
</thead>
</table>
| Displacement not appearing correctly | The icosphere is without UVs  
`Solution: you must change the coordinates of the texture to “generated”` |
| Displacement not detailed enough | There is not enough geometry to displace  
`Solution: Increase subdivision modifier`  
`Note: ”view” effects viewport render ”render” effects the final render` |
| Odd clipping on collision tube | The nurbs path has control points in the wrong order  
`Solution: move control points in a straight line in sequential order` |
| Kill plane or collision tube shows in render | Unwanted geometry is set to render  
`Solution: toggle the camera icon in the outliner to exclude the object from render or viewport` |