Introduction

Microsoft Excel is a powerful tool for data analysis, however, it is rather expensive and can be a bit overwhelming to someone with no experience in a similar program. For those of you looking to avoid spending too much on a copy before you’re sure you can use Excel, it is installed on all of the computers in the DMC, and any Rice student is welcome to come use them. There are also free alternatives online, such as Libre Calc, which is included in the Libre Office suite.
This student-oriented guide will help you get into entering, editing, and displaying data using the powerful tools Excel has to offer. This guide has three main parts to it; part 1 explains how to enter data into Excel, part 2 explains how you can use Excel to manipulate that data, and part 3 shows you how to display that data using various charts and graphs in Excel.

Part 1: Entering Data

1.a: Typing

To start using Excel, you first have to open the program. When running, you should see an application window filled with tiny boxes. These boxes are called cells. To start entering data, or anything, really, click on one of these cells. You should see a darker, thicker box appear around that cell, signifying it’s been selected. Once you’ve selected a cell, you’re free to type anything you want, and you’ll see what you type appear on the screen in two places: inside the cell itself, and in the “formula bar” near the top of the screen. It’s best to avoid starting a cell with a few certain characters. For instance starting with an equal sign (=) or an apostrophe (‘) without knowing what these do could give you results you don’t want. We’ll get to what these characters do later.

Once you’ve typed in the information you want, you could click on the next cell you want to start entering data into, but it’s generally faster and easier to use the keyboard to navigate between cells. This way you can continue typing without ever having to move your hands from the keyboard.

1. Press “tab” to move your selection to the cell to the right of your current selection.

Tip:

If you can’t find the formula bar, it may have been hidden. Click View ➔ Show, and check the “Formula Bar” box to bring it back.
2. Press “enter” to select the cell underneath your current selection.
3. Hold “shift” while pressing either of these buttons to reverse the direction of motion.
4. You can also move around the cells with just the arrow keys

1.b: Editing Cell Properties

Sometimes, it will be necessary to have different sizes and colors of cells (you may have noticed that any text that is too long for a cell either covers up the next cells or is covered up itself). While there’s a lot more you can do with cell properties than just those, we’ll keep to the basics for now.

Quickly, we’ll go over different ways to select cells first.

1. Clicking. Easiest way to select a single cell.

2. Clicking and dragging over cells. Selects a box of cells, very useful for clearing a large number of cells fast.
3. Clicking a column or row label. When you click on the label for a column or row (the letters at the top of the field of cells and the numbers to the left) the entire column or row gets selected. Note that you’ll see your cursor change into an arrow when you’re about to make the selection.

4. Clicking and dragging over columns or rows. By clicking and dragging over the column labels, the entire set of columns or rows gets selected.

Now on to editing. You have three options for changing the size of the cell: changing manually, typing in a new size, or having Excel resize the cell for you.

1. To change the cell size by hand, hover your cursor over the line that separates any two column labels or row labels (again, this is at the edge of the field of cells), you’ll see your cursor change to a line with two arrows coming out of either side of it. Click and hold, and you’ll be able to move that line.

2. To type in new sizes for a cell or cells, first select the cells you’d like to alter. Click on the “Home” tab, then, under the “Cells” group, click “Format.” You’ll see a drop-down menu appear where you can change the row height of all your selected cells and the column width of all your selected cells.

3. In the drop-down menu from the above step, you can also click on the AutoFit option to have Excel resize your selected cells for you.
Changing colors/styles is just as easy. Click on the “Home” tab, then, under the “Styles” group, you’ll see a wide selection of styles to choose from, just select the cells you’d like to change and click away.

We mentioned at the beginning of this section that you could do a lot more with cell formatting, if you’d like to spend more time getting your cells up to snuff, right click on any selection of cells and then click “Format Cells…” to see the full range of control you have.

1.c: Series and Alt- Modifications

Now let’s say you wanted to fill 20 cells with the number 2, or, more likely, with the numbers 1 through 20; you don’t need to type every number to fill the cells, generally, if the data follows some kind of pattern, Excel can fill it in for you.

1. First, select a cell and enter in the first value you want (for this example, we’ll use a 1).

2. After you’ve entered the information, select the cell again; you should see a tiny black square at the lower righthand corner of the cell. If you hover your mouse over this square, you’ll see the cursor change from a white plus sign to a black plus sign.

3. Click this box, hold, and drag along the set of cells you’d like to fill. You’ll see a grey outline appear around the cells you’re filling, and a number appear next to your
cursor. This number is the number that will appear inside the last cell you are filling.

4. When you release the mouse, you’ll see the cells fill up with those values and a menu box appear near the tiny black box.

5. If you click on this menu, it gives you several options for filling in the cells, including “fill series.” By clicking this button, you are telling Excel you want the dragged data to follow a pattern, rather than fill the same thing in each time.
6. You can also hold the “Ctrl” key while dragging to switch fill modes before you fill to begin with. (If “Ctrl” doesn’t work for you, try the “Alt” key by itself too, some versions of Excel use “Alt” instead)

For some series (days, months, patterns, etc.) Excel will catch on automatically, and there’s no need to hold Ctrl- or Alt-, if you’ll be using this feature very often, it’s best to toy around with it on your own to get used to it.

1.d: Copying and Pasting

Suppose you had a table like this:

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Food</strong></td>
<td><strong>Cost ($)</strong></td>
</tr>
<tr>
<td>Eggs</td>
<td>1.50</td>
</tr>
<tr>
<td>Bread</td>
<td>2.00</td>
</tr>
<tr>
<td>Milk</td>
<td>1.75</td>
</tr>
<tr>
<td>Chicken</td>
<td>4.50</td>
</tr>
<tr>
<td>Apples</td>
<td>0.75</td>
</tr>
</tbody>
</table>

Each entry is separated by a “tab” character, and each row is separated by an “enter” character. These are the same buttons/characters you would use in Excel to enter this data. This means you can select this list, copy it, select the cell you’d like to start in in
Excel, and press paste; “Food” will appear in the cell you selected, “Cost ($)” in the cell next to it, then “Eggs” in the cell underneath “Food,” and so on. The data appears just as if you had typed the tab and enter buttons yourself.

Part 2: Manipulating Data

2.a: Sorting

Sorting large lists is a very convenient thing Excel can do for you. Let’s look at our previous example:

Let’s say you needed these groceries in order of decreasing cost.

1. You’d start by selecting all the cells with the data you’d like to sort, then, under the “Data” tab, by clicking the “Sort” button under the “Sort & Filter” section. You should get this dialogue box:
2. Under “Column,” you can select which column you’d like to sort by. For the sake of this example, we’ll sort by “Cost ($).”

3. Our sorting parameter (what criteria we sort on) is the values in the cells.

4. We chose to sort this list from “Smallest to Largest” as you can see in the dialogue box below.

5. The result of this sort is a sorted list:
6. Sometimes, it becomes necessary to sort a list by two parameters (such as a list of first and last names); to do this, you can click the “Add Level” button. You’ll get a new row of parameters to sort by after the more-important first layer has been completed.

Excel also offers a simpler way to sort, if you’re only going to be sorting on a single parameter, which we’ll cover here briefly.

1. Select a cell in the column you’d like to sort by.
2. Click on the “Data” tab and find the “Sort & Filter” section.
3. Click on either of these buttons. The first is to sort descending (“From A to Z”) and the second is to sort ascending (“From Z to A”).
4. Just because you only have one cell selected, doesn’t mean Excel will only try to sort that one cell. Excel will automatically select and rearrange all the other data you’re working with as well.

2.b: Simple Math

You’ll often run into situations in Excel where the data you have is not the data you want to display. Below we have a list of runners, and times it’s taken them to complete the various races they’ve run in.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C (meters)</th>
<th>D (Time)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>First Name</td>
<td>Last Name</td>
<td>Race</td>
</tr>
<tr>
<td>2</td>
<td>Sara</td>
<td>Miller</td>
<td>50</td>
</tr>
<tr>
<td>3</td>
<td>Norma</td>
<td>Mitchell</td>
<td>100</td>
</tr>
<tr>
<td>4</td>
<td>Paula</td>
<td>Powell</td>
<td>400</td>
</tr>
<tr>
<td>5</td>
<td>Chris</td>
<td>Bennett</td>
<td>250</td>
</tr>
<tr>
<td>6</td>
<td>Diana</td>
<td>Hughes</td>
<td>1000</td>
</tr>
<tr>
<td>7</td>
<td>Aaron</td>
<td>Stewart</td>
<td>100</td>
</tr>
<tr>
<td>8</td>
<td>Earl</td>
<td>Walker</td>
<td>400</td>
</tr>
<tr>
<td>9</td>
<td>Wanda</td>
<td>Torres</td>
<td>100</td>
</tr>
<tr>
<td>10</td>
<td>Ann</td>
<td>Williams</td>
<td>1000</td>
</tr>
<tr>
<td>11</td>
<td>Jean</td>
<td>Wood</td>
<td>400</td>
</tr>
</tbody>
</table>

While this is useful on its own, you might want to have the speed of the racers as another metric. As you can probably guess, this isn’t something you need to calculate by hand and fill in for every racer, but something you can get Excel to do for you.

1. You’d first start by naming the topmost cell in the column “Speed” (this isn’t necessary for any of the following steps, but it’s nice to keep things in order).

2. In our example, because speed = distance / time, in cell E2 (that’s column E, row 2, in case you were wondering), we would type “=C2/D2”.

   a. The “/” tells Excel that you’d like to divide the value on the left by the value on the right

   b. The C2 and D2 tell Excel that those cells hold the values we’d like to operate on (these could be replaced by actual values, but we’ll see why using cell references is better in this case in a moment)

   c. The “=” tells Excel to set the current cell equal to that value.
3. Remember clicking and dragging the black square to make Excel follow patterns? Well, it works here too. **We can just select the one cell with the operation we want in it, and drag it down to fill all the other cells with the same operation, but done on their own respective cells.** Unless you tell Excel otherwise, it will always think that calculations on other cells should be done relative to the starting cell.

Of course Excel can do more than just divide two numbers. A list of all basic operators is below, though, as we’ll learn in a moment, there is much, much more than this. Keep in mind Excel will follow proper order of operations with the following operators.

**Tip:**
Note that, even though the number appears in the cell itself, its formula still shows in the “Formula Bar” just above it.
<table>
<thead>
<tr>
<th>Symbol</th>
<th>Operation</th>
<th>Example</th>
<th>Result of the Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>Equality, either sets a cell equal to a value (if it is the first symbol entered into the cell) or checks for equality between two values. When used to check equality, it is called a boolean operator; we won't cover these in this guide, though you're free to look up how they (and the IF function) work.</td>
<td>=12 or =3=5</td>
<td>12 or FALSE</td>
</tr>
<tr>
<td>+</td>
<td>Addition</td>
<td>=3+5</td>
<td>8</td>
</tr>
<tr>
<td>-</td>
<td>Subtraction</td>
<td>=6-2</td>
<td>4</td>
</tr>
<tr>
<td>*</td>
<td>Multiplication</td>
<td>=3*7</td>
<td>21</td>
</tr>
<tr>
<td>/</td>
<td>Division</td>
<td>=12/4</td>
<td>3</td>
</tr>
<tr>
<td>(</td>
<td>Parenthesis, tells excel to perform sets of calculations inside them first</td>
<td>=(3+2)*4</td>
<td>20</td>
</tr>
<tr>
<td>^</td>
<td>Exponentiation</td>
<td>=2^3</td>
<td>8</td>
</tr>
<tr>
<td>&amp;</td>
<td>Concatenation of strings of text</td>
<td>=“he”&amp;“llo”</td>
<td>hello</td>
</tr>
</tbody>
</table>

2.c: Functions and the Function Browser

Quite often, the few operations we described above will not be enough to cover all the calculations you need; for those times, Excel offers a wide variety of built in functions which you can use by simply typing the name of the function followed by parenthesis with the appropriate data inside. Here’s how to find and use any function you might need:

1. To the left of the formula bar is a small button labeled “fx”. Click this button to open the function browser.
2. Once you've opened this browser, you should notice the hundreds of functions available to pick from, along with a field you can use to search for specific functions, and a drop down menu that lets you narrow down functions by type.

3. After you choose a function and click “OK”, another window will pop up that lists all the inputs to the function, and what those inputs are expected to look like.

4. A faster way to enter in cell references into this window is to simply **click on the field you’d like to fill, then click on the cell you’d like to reference; Excel then fills in the reference for you.** This works any time you’re entering a function, actually, not just in this function browser window.

5. Once you’ve filled in all the necessary information, press enter (or the “OK” button) and the cell you had selected is filled with the function you chose.
There are some functions that can take a huge number of inputs. For example, the SUM() and AVERAGE() functions can both take a virtually unlimited number of inputs. It could easily get tedious to select every cell you want, for this reason, **Excel also lets you select a range of cells as the input to a function.**

Here’s what it looks like to select a range of cells. You can either type in the cells as a range (A1:D20 means we want all cells in between cell A1 and cell D20) or click and drag over the range you want in the Excel window itself rather than this arguments window.

**2.d: The Dollar Sign**

Often times you’ll see a “$” in Excel calculations, it’s not as important an operator as something like “+” but it’s important enough to warrant its own brief section. Placing a dollar sign inside cell references in calculations prevents Excel from changing that reference when trying to follow a pattern.

Using $D$2 in a calculation means that, no matter where you drag that operation, the reference will always be to cell D2. Keep in mind the “$” only works on the very next value; $A5 will always stay on column A, but not row 5, whereas C$17 will always stay on row 17, but not column C.

If this seems a bit confusing, try it out yourself with a few simple calculations. If you still can’t grasp it, don’t worry about it. The dollar sign is a fairly confusing operator that’s easy to work without, but convenient when it’s needed.
Part 3: Displaying Data

3.a: Choosing a Chart

As I’m sure you can imagine at this point, Excel has a range of charts you can choose from that’s as diverse as the functions it offers you. Picking a chart can be a bit difficult, this guide expects you to know what kind of data should be placed in which kind of chart, so we’ll move right into what Excel 2010 expects when making a chart for you.

1. Excel likes to see things placed in columns, with a label at the top of each column. (You could also organize it in rows, if you prefer scrolling side-to-side rather than up and down, Excel can still catch on)

2. For this example, we’re using the same data for runners as earlier. You can see it’s formatted just as Excel likes to see it. All we have to do is select the range of data we’d like to display.
3. Click on the “Insert” tab and find the “Charts” section. We’d like to display this data using a column chart, so we click “Column” and find the one we’d like to use (for most cases, that will be the very fist selection in the column chart menu.)
4. Click it, and Excel does most of the work for you. You can see Excel has put the data we had in the left-most column on the x-axis, and everything to the right of that on the y-axis. It even took the column labels and used them as data labels (this is how Excel assumes data is generally organized).

5. You should notice when Excel makes a chart for you that a new set of tabs pops up at the top of the window. These tabs, grouped together by a big green box, are your Chart Tools. You should review the options you have for editing the chart before we move on, especially under the “Design” and “Layout” tabs. We’ll cover formatting your chart in the next section.

As another quick example, here are some cost predictions for various products on the market:
Again, we select all the data we want to display, but now click Insert ➔ Charts ➔ Line (picking an appropriate line graph), and we get the following:

Once again, Excel has automatically grabbed the information you input and figured out where it fits in the chart, even with 4 columns of data.

Sometimes the data you want to display won’t all be adjacent to each other. For these cases, you can hold down the “Ctrl” button on your keyboard to make multiple selections. By selecting with this method, the selections can be made separately, so the right data is selected, but highlighted such that Excel can still figure it out.
### 3.b: Formatting Charts

Our chart of runner speeds looked fairly useless as it was; let’s go back and touch it up a bit.

1. First off, that label on the right is pretty pointless here, we can just select it by clicking it, and press delete or backspace to delete it.

2. That’s really not the title we’d want for this graph, but we’ll change it rather than delete it. Select the text box with the title in it, then click inside the box where you’d like to place the text cursor. From there, you’re free to edit to your heart’s content.

3. The next thing we’ll want are some axis labels. To get these, select the chart, the go to Layout ➔ Labels ➔ Axis Titles. When you click on “Axis Titles” you’ll see the following menu:
4. Both of these options give you the option to place a title on their respective axes.

5. Don’t like the default font? You can just right click on the text box with the font you’d like to change in it. You’ll get a pop-up menu of new fonts to choose from, as well as a “Font...” option. Both can be used to change the font.

6. A menu for pretty much anything else you’d like to change on the chart can be found by double-clicking on the chart area itself. Double clicking on blank space in the chart will let you add a fill to the chart background, double clicking on the data labels will let you change their spacing and orientation, and double clicking on the points of data themselves will let you change how the data is represented on the chart (color, spacing, symbols, etc.). Combining all of these can get you some pretty astounding charts.

7. Once you’ve got your chart the way you want it, you might want to move it somewhere else. Right click on the graph, and you have the option of copying and
pasting it into a Word or PowerPoint document. You can also copy and paste it into Microsoft Paint, where you can then save it as a still image. You could even click “Move Chart” to move it to another sheet in Excel, where it is automatically resized to be ideal for printing.

Part 4: Integration With Other Microsoft Office Products

Excel, while great for number manipulation and data processing, falls flat at things like writing a coherent lab report and making a gripping presentation. For these purposes, you might have access to Microsoft Word and Microsoft PowerPoint respectively, and we can assure you that these programs are sold in a package for a reason.

**Word**

In Word 2010, you have the option to insert tables and charts (under the “Insert” tab), these tables and charts will look and behave the same as the ones from Excel, even most of the menus you see when accessing these functions might resemble what you’re already familiar with in Excel. Inserting a chart will open up an Excel window which you can use to edit the chart it inserts there for you.

If that’s all too confusing for you (or you may already have the perfect chart made in Excel) you can also select whole charts in Excel, and just copy and paste them into your Word document, you won’t have to worry about Word reformatting too much.

**PowerPoint**

In PowerPoint 2010, any time you create a new slide, you should notice the 6 symbols in the middle of some text fields. The first two symbols should look familiar; they are a table and a chart. When you click on the table, it will ask you how many row and columns you’d like, once you’ve decided, the table that appears behaves just like the cells in Excel.

When you click on the chart button, you’re taken one step further, PowerPoint will open up an Excel window which you can use to edit the chart it inserts there for you (even the chart formatting system itself seems identical to what you should know in Excel).

While these buttons automatically format your data to look pretty, it may also be easier to copy and paste what you need from Excel directly, just like you could with Word.