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Part I – Introduction 
 

1. What is Flash? 
Flash is a tool used to create simple and complex animations for web sites as well as 
games and simulations. Flash uses vector graphics, which means it can be resized without 
losing quality and is relatively small in file size. Flash content on a web site is displayed 
by Flash player, which is a free browser plug-in and supported by all popular web 
browsers. This allows virtually everyone to access Flash media on the Internet. 

2. Typical web sites that use Flash movies 
a. Web sites enhanced by Flash 

i. Rice home page: http://www.rice.edu/ 
ii. YouTube: http://www.youtube.com/ 

b. Web sites based on Flash 
i. A Philadelphia Web Design and Advertising agency 

http://www.singularitydesign.com/ 
c. Sample Flash animations 

i. Rice University 2009 holiday greeting card 
http://www.rice.edu/holidaycard/ 

ii. Adobe Flash Developer Center 
http://www.adobe.com/devnet/flash/samples/ 

iii. NASA online http://www.knowitall.org/nasa/simulations/science.html 
3. How should webmasters work with Adobe Flash? 

a. Use it when it is needed since some textual contents stored in Flash as graphics 
can be missed entirely by search engines– Google webmaster central blog 
http://googlewebmastercentral.blogspot.com/2007/07/best-uses-of-flash.html 

b. Use Flash as a tool to enhance web site and web content, not as a replacement to 
HTML due to Flash’s accessibility issues, compatibility problems, etc. For a list 
of drawbacks in using Flash for a website, go to: 
http://www.bjornenki.com/blog/why-flash-based-websites-are-discouraged - 
drawbacks 

4. Flash Workspace 
Flash’s workspace consists of six main components: a Menu bar on the top that 
organizes commands within menus, a Stage in the center where objects are displayed, a 
Timeline below the Menu bar used to organize and control objects on the stage along a 
time axis, a Tools panel on the left, a Properties panel at the bottom, and one or more 
panels on the right.  
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- picture	  from	  “The	  Web	  Collection	  Revealed”,	  book	  by	  Sherry	  Bishop,	  Jim	  Shuman,	  &	  Barbara	  M	  

Waxer	  	  

• Menu Bar: It contains basic functions such as creating and saving files, as well as 
special functions such as exporting and publishing. It also contains commands 
such as testing movie, opening a panel, etc. 

• Stage: Think of the stage as an actual performance stage. Everything placed on 
the stage will be seen by your viewers. The gray area surrounding the stage is the 
Pasteboard. You can use Pasteboard as the extension to the stage or your scratch 
space. But keeping this in mind, neither Pasteboard nor the objects on it will be 
visible to your audience. You can draw objects directly on the stage or drag them 
from the Library Panel to the stage. The stage size is also your Flash document 
size. You can change it using the Properties panel. 

• Timeline: The Timeline organizes and controls an animation’s contents over time. 
With Timeline, you can determine what will be happening next, which object will 
be animated and how an object will be animated. 

 
-‐	  picture	  from	  “The	  Web	  Collection	  Revealed”,	  book	  by	  Sherry	  Bishop,	  Jim	  Shuman,	  &	  
Barbara	  M	  Waxer	  	  
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• Tools Panel 

 
The Tools panel contains a collection of tools for you to select, create, and 
manipulate objects on the stage. When you mouse over a tool, its name appears 
next to the tool. When you see a black triangle at the right corner of a tool, you 
can press and hold down left key on your mouse to reveal more tools that are 
grouped under this tool.  

• Properties Panel   It is used to change the properties of an object, such as the 
background color and size of a document, and the fill color of a rectangle.  

• Library Panel  It is the place where you store and organize symbols created in 
Flash, as well as imported files, including bitmap graphics, sound files, and video 
files.  

 
Part II Starting a Flash Project  
 

1. Starting a Flash Project 
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a. Launch the Adobe Flash CS3 program, click Flash File (ActionScript 3.0) 
under Create New. 

b. To save a new created Flash project, go to File > Save. The extension of the 
saved project file is FLA. This file can't be opened without Flash application.  

c. To have a portable flash movie file, once you are done with your project, go to 
File > Publish. The default publishing format  is SWF (SWF stands for 
Shockwave Flash). SWF files will play on any computer with Flash 
player.  Alternatively, you can export a Flash movie as an animated GIF (GIF 
stands for Graphic Interchange Format) that is even more compatible with 
web browsers. 

d. Setting Document Properties – when you start a new Flash project, the default 
document settings are: Document Size - 550x400 pixels, Background color – 
white, and Frame rate -12 fps. You can change these settings in the Properties 
panel at the bottom of the Flash interface, or go to Menu bar, Modify -> 
Document.  

i. Document Size – it is also the Stage size or frame size of the movie. It 
is measured in pixels. For animated movie that will have most of its 
life on web sites, it is not recommended to have big frame size. The 
bigger the frame size, the bigger the file size. 640x480 pixels, 320x240 
pixels, 240x180 pixels are common web video sizes. Just to give you 
an idea what the frame sizes are when measuring in pixels:  NTSC 
movies on TV -  720x480,  high definition movies - 1440x1080 or 
1920x1080. 

ii. Background color – it defines the background color on which your 
artwork appears. 

iii. Frame rate – it is the number of pictures played per second. NTSC 
movies on TV are 30 fps, movies played in theatre are 24 fps. The 
bigger the frame rate, the bigger the file size. 12 fps is a good value to 
start with to create smooth animations on web sites.  

2. Creating graphics  
You can create graphics objects in Flash using the drawing tools. 
E.g. Drawing a circle  

i. Click and hold the Rectangle tool on the Tools panel to display the list 
of tools, and click the Oval tool.  

ii. On the Properties panel, choose the stroke and fill color respectively 
iii. Hold down Shift key, then drag the Oval tool on the stage to draw a 

circle. (Pressing and holding shift key creates a perfect circle.) 
 
Part III Frame-by-frame animations 

Frames contain content that your audience will see in the animation. Each frame represents a 
moment of time in an animation.  
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The rectangles on the left are example of frames. Every fifth frame appears 
gray, making them easy to count at a glance. The red square is your play 
head. Dragging it around with the mouse lets you "scrub" through your 
project, previewing it as you work by simulating the animation process. 

A Key Frame represents a point on the Timeline where a change occurs in the animation. (a 
change can be add content, subtract content, position change of an object, etc.) 

 

These are examples of keyframes.  
The keyframes on top layer are solid black dots, telling you that they contain 
objects. The keyframe at the bottom layer is a white dot, which means it is blank.  
The keyframe on the left at the top layer is one frame long, while the one on the 
right at the top layer is eight frame long.  

To work with the contents of a certain keyframe, click its first frame (the one with the black dot). 
It is now selected and its contents will appear on the stage. 

To add a blank keyframe: 
Click on an empty section of the timeline, press F7 or choose Insert->Timeline ->Blank 
Keyframe 

Essentially, frame-by-frame animation works by creating a unique image in each frame. Each 
frame then becomes a keyframe since there is a change that alters the animation.  

Here is an example of simple animation.  

 

Here is the first keyframe. 

 

Here is the second keyframe. 
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Here is the third keyframe. 

Put them together and you get... simulated motion! Frame by frame animation, though 
sometimes useful, is very labor intensive and has a tendency to create very large files. 

 
Part IV Animation with Motion Tweening and Shape Tweening 
 
Flash simplifies matters with a kind of animation called Tweening. Once you create start and 
end frames, Flash generate a smooth series of frames that fill the inbetween space (i.e. In-be-
TWEEN). There are two types of tweened animations: motion and shape. Motion Tweening is 
animation in which objects are resized, repositioned, rotated, and recolored. Shape Tweening is 
similar to image morphing in which one object slowly turns into another object, such as a robot 
that turns into a person. Since Tweening uses instances of symbols, let’s talk about what symbols 
and instances are. 
 
Symbols and Instances  

A symbol is a self-contained object within a Flash animation which can be used multiple times. 
This is very useful for making changes throughout an animation. Say you are animating a picture 
of a rocketship, and the same rocket appears in 30 different frames. If you decide later on that 
your rocket needs to be blue instead of red, or have the words "Big Bertha" emblazoned on the 
side, imagine what you must do if each rocket is a collection of lines and fills. 30 frames must be 
individually changed and perfectly matched! You may as well give up and start over, unless your 
rocket is a symbol! By creating a picture as a symbol, you create a "master copy" which sits in 
your project's library. Making changes to the master symbol will affect all its instances 
throughout your Flash project. 

To create a symbol from a picture you have already drawn: 

1. Select all the elements of the picture you wish to be part of your instance. Use the 
rectangular marquee, the lasso, or click on elements while holding down the SHIFT 
key. 

2. Choose Modify > Convert to Symbol from the menu bar. 
3. Give your symbol a name, and select its type (graphic symbols are the most basic). 

The new symbol should now reside in your Library. 

To create a new symbol from scratch: 

1. Choose Insert > New Symbol from the menu bar. 
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2. Give your symbol a name, and select its type. 

Symbol Types: 

Symbols come in three varieties: 

Movie Clip:  

Movie clips are generally used by advanced Flash users to create animations which 
can start and stop interactively. An animated Movie clip will play continuously, even 
if it is placed in a project only one frame long.  

Graphic: 

This is your basic Flash symbol. Its animation is dependant on the project's timeline. 
This means that if a Graphic Symbol is 35 frames long, and it is placed in a project 
only 24 frames long, the symbol's animation will reset on the 24th frame. 

Button: 

Buttons are used to provide interactivity. They are symbols with four frames, one for 
each button state - Up, Over, Down, and Hit which correspond to the use of the 
mouse.  

 
1. Motion Tweening 

To create a motion tween: 
a. Create two blank keyframes on the timeline using the F7 key 
b. Fill each keyframe with instances of the same symbol 
c. Move, flip, and resize the instances in one or both frames. Your animation will be 

the transition between the two, so the differences are what make it interesting. 
d. Lengthen your first keyframe using the F5 key which inserts frame. This defines 

the length of the transition.  
e. Right click any frame between the start and end keyframe, from the popped up 

window choose Create Motion Tween. 
f. Hit Enter to play the animation you just created. 

 
A good rule of thumb when doing Motion Tweening: 

• Only instances of symbols can be motion tweened. If you select an object that 
is not already a symbol in the library and create a motion tween, Flash 
automatically creates a symbol, names it Tween 1, and places it in the Library 
panel.  

• Only one symbol per layer can be motion tweened! (You can make as many 
layers as you want. Remember to name them so you don’t get confused.) 
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           Guide Layers - Guide layers allow you to direct a motion tween, and make a symbol take 
an indirect path to its destination. 

To Create a Guide Layer: 

1. Click the Add Motion Guide button on the Layers section of the Timeline. This 
creates a new layer on top of the layer you have selected. 

2. Click on the Motion Guide layer to make sure it is the active layer. 
3. Click on the Pencil tool in the left toolbox. Set the Pencil Mode to Smooth. 
4. Draw a line beginning on the image and ending at the other side of the Stage. 

Imagine this is a track and your symbol will be the train. 

Here's an example of a good guide layer: 

 

To Match a Motion Tween to a Guide Layer: 

1. Create a Motion Tween using the steps from the previous section. 
2. Extend the duration of the guide layer keyframe by clicking on it and then 

pressing F5. It needs to have the same duration as the motion tween. 
3. Using the mouse, grab the Transformation Point (shown as a mall circle) on the 

center of the symbol from the first frame of the motion tween . 
4. Drag the Transportation Point of the symbol to the beginning of the Guide Layer's 

path. 
5. Now drag the symbol from the ending  frame of the tween onto the very end of 

the path. 
6. Hit Enter to play the animation. 

 
2. Shape Tweening 

Shape tweening creates an animated transition from one vector image to another. You 
may have seen similar effects on TV or in movies, where one person or object "morphs" 
into another.  
To create a shape Tween: 

a. Create two keyframes on the timeline using the F7 key.  
b. Fill each keyframe with a different vector graphic. 
c. Lengthen your first keyframe using the F5 key. This defines the length of the 

transition. (Your ending frame can be as long or short as you want it.) 
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d. Right click any frame between the start and end keyframes and select Create Shape 
Tween. 

e. Hit Enter to play the animation. 

 
Part	  V	  Publish 

Once you are done with your flash movie, you can go to File -> Publish Settings to set up the 
Publish Settings. Flash offers a series of file types to which your creation can be published. 
Typical file formats are SWF and GIF. 

 
Appendix – Animation terminology 
 

Glossary: 

Alpha: the amount of transparency in a symbol instance. When Alpha = 100% the symbol is 
opaque. When Alpha = 0% it is completely transparent (i.e. invisible). 

Bitmap: any picture file not made of vectors, such as JPEG's GIF's and BMP's. 

Frame: a single increment or picture on the Flash timeline. Animation happens when large 
numbers of these are displayed in fast succession. In Hollywood movies this is when a series of 
photographs are projected on a screen at a rate of 24 frames per second. 

Frame rate: the number of frames that pass the screen every second.  

Inspector: a window which contains options to control the characteristics of selected objects 
such as texture, stroke, etc. 

Instance: a duplicate of a symbol. Instances can be changed in size, copied, and deleted without 
altering the original symbol, which resides in your library. 

Keyframe: A keyframe is a frame in which you define a change to an object’s properties for an 
animation. 

Library: A panel within Flash displaying all your project's symbols, sounds, pictures, etc. 

Object: any entity within your Flash project, such as a polygon, a line, or a bitmap. 

Onionskin: This option displays several (you decide how many) frames at once. The single 
frame highlighted in the timeline will remain solid, while the other frames appear somewhat 
transparent. Onionskin is useful for aligning and spacing graphics across multiple frames. 

Panel: a window which contains options to control tool characteristics, or collections of assets. 
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Scrub: to grab the red play head with the mouse and drag it back and forth across the timeline, 
simulating the final animation process. 

Stage: the central "screen" of your main project window. When working with Flash this is where 
all the graphics and animation are previewed. 

Symbol: a self contained object within a Flash animation which can be used multiple times. 

Timeline: part of the Project window where frames, keyframes, and tweens are arranged on a 
numbered grid. 

Tween: a method of simplifying the animation process. Flash is given initial and final 
keyframes, and generates a series of inbetween frames. 

  

References:	  	  	  

• Adobe	  Flash	  Developer	  Center:	  http://www.adobe.com/devnet/flash/	  


