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Part | - Getting Started

1. A few Updates of Rice CampusPress platform
o No longer called WordPress, but CampusPress
o Some old themes retired and new mobile friendly themes added
o More widgets and plug-ins added
o More quota in media library
o More information about the updates: http://about.blogs.rice.edu/
2. Decide what you want to include on your site
Typical sections on an academic web sites include:
o CVand Short Bio
Research
Teaching
Publications
Groups
3. Decide how to establish a professional presence online

1) Decide who your audience is, what your goals for the site are, and what kind of image you
want to project.

2) Use professional language; proofread carefully.

3) Aim for a design appropriate to your image; the design should not be a distraction. For
examples of what not to do, see "The World's Worst Web Site"
(http://www.angelfire.com/super/badwebs/) and "Web Pages That Suck"
(http://www.webpagesthatsuck.com/)

4) Keep your site up-to-date.

5) Write for the web. Make your site easy to skim by using bullet lists, short sentences and
paragraphs, and section headings. Try to incorporate images and other media to give your site
some visual flair.

6) Respect copyright, but also understand your own rights
a. Any work (photo, text, video, music, etc.) is automatically copyrighted as soon as it takes

physical (or digital) form.

b. Don't use copyrighted images or other content on your web page without permission; you
don't want to get sued, and you should respect the creator's rights.

c. However, if you are using the copyrighted material for teaching, research or criticism, you
may be able to claim fair use. To evaluate whether you have a fair use claim, consider four
factors: 1) amount and substantiality of the work (if you are using just a small portion, that
weighs in favor of fair use); 2) purpose of the usage (if you are commenting on the work or
developing an educational project, that tilts towards fair use); 3) nature of the material (if
it’s factual, that weighs in your favor); and 4) economic impact (if the copyright holder is
unlikely to lose money because of your usage, that supports fair use). See
http://www.utsystem.edu/OGC/IntellectualProperty/ and http://fairuse.stanford.edu/

d. Creative Commons: An increasing number of creators are choosing to share their content
through a Creative Commons license (http://creativecommons.org/), which defines how
people may use a creative work. For instance, a Creative Commons license may say that

@)
@)
@)
@)
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you can use this work as long as you attribute it, or as long as the usage isn’t
commercial. Increasingly you can find copyright free (Creative Commons) media that you
can reuse in your work. You can search for such content via the Creative Commons site:
http://search.creativecommons.org/
Good sources for copyright-free images include:

i. Flickr: Go to advanced search and check “Only search within Creative Commons-

licensed content.” Be sure to attribute whatever images you use.
ii. Google Images: Go to advanced search and choose “labeled for reuse”

7) Share your work if you want to create a website for your portfolio.

a) You can apply a Creative Commons license to your own work, provided that you haven't
signed the rights away to a publisher. By sharing your work openly, you increase its
visibility and make it accessible to researchers at institutions without large library
budgets. See http://creativecommons.org/choose/ and
http://sciencecommons.org/about/

b) You can share your papers, presentations, and other work via the Rice Scholarship archive,
http://scholarship.rice.edu/
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Part Il - Creating a professional web site using Rice’s CampusPress
Platform

1. Create your site.

a. Visit http://blogs.rice.edu/wp-signup.php. (If you don't want your site hosted by Rice, you
can instead create a free blog directly at http://wordpress.com/. Alternatively, you can
contract with a web site hosting service that supports WordPress, such as DreamHost,
BlueHost, or WebGator.)

b. You will be sent to your dashboard after log in. To create a new site, click Create a Site to
the right of your dashboard.

c. Inthe window below, you will need to provide a hostname to use (e.g.
whateveryoupick.blogs.rice.edu) and a name for your site (e.g. “My name” or “department
name” or “My pithy phrase”). You can choose the language your site will be using. Then in

privacy settings, you can choose to make it public or limit access to your site .
Site Domain:

.blogs.rice.edu

Site Title:

Language:
English

Privacy:

® Public
Search Engine Blocked
Visitors must have a login - anyone that is a registered user of Rice University Blogs can gain access.
Only registered users of this sites can have access.
Only administrators can visit - good for testing purposes before making it live.

Anyone that visits must first provide this password:

Note: Anyone that is a registered user of this site won't need this password.

d. You can also define whether your site is visible to Google search.
e. Click ‘Create a Blog’, you will be sent to your website dashboard.

Hint: you can instead log in and go the Site Admin section by typing /wp-admin/ after the main
web address for your site, as in http://myblogname.blogs.rice.edu/wp-admin/
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2. Screen Options
Screen Options, displayed as a hanging tab under the toolbar, allow the user to decide what fields
or modules are presented in the work area for a given Administration Screen. Each Screen may
have a different set of Screen Options. Click on the Screen Options tab to expand the options
available for a particular Screen, check (or uncheck) the desired options, then click the Screen
Options hanging tab to collapse the Screen Options.

Show on screen
Posts \21 Links }2[ Categories Tags \?[ Format Iz Pages
Show advanced menu properties

Link Target CSS Classes Link Relationship (XFN) Description

Screen Options

3. Navigation Tools
New to blogs.rice.edu is the CampusPress fly-out navigation tools. Hover over each section to see
the options underneath. If you click on one of the sections, that section will expand and stay open
while you are on that set of tools.

1) Posts: The Posts tool is where you can add new posts, edit existing posts and edit tags and
categories for your posts.

2) Media: The Media tool includes your Library that lists any images, audio and video files you
have already uploaded. The Add New link helps you upload new media to your library.

3) Links: Links are hyperlinks to other Web sites or blogs. You can include this in your sidebar by
adding the Widget called Links. Look under Appearance > Widgets. Use the Links tool to edit
your existing links, add new ones or organize your categories for links.

4) Pages: Pages are static pages on your blog. They are different from posts. Pages can include
information about you or the site and are not time sensitive like a post.

5) Comments: Comments are a way for you to get feedback from your readers. The Comments
section allows you to administer your comments to approve, reply, edit, mark as spam or
delete. By default, your site will moderate all comments from new people. We also have
Akismet spam protection installed.

6) Appearance: The Appearance tool allows you to change the look and feel of your site. There
are over 50 themes loaded and themes can be changed at any time. Click on each theme to
preview what it will look like before you decide. Any options that come with the theme you
have selected will be located under the Appearance menu.

(Note: If you change your theme and have customized your widgets, they may seem to
disappear from your site. They are still available under Appearance > Widgets in the Inactive
Widget section. Simply drag them back to the sidebar in your new theme.)

7) Plugins: Plugins are extra bits of code that add additional features to your site, including links
to social media and Google Maps.
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8) Users: The Users tool shows you the people contributing to your site. You can add other
people who have a Rice NetID to your site as authors, editors, contributors, etc. You may also
edit your profile here.

9) Tools: This set of tools has a couple of CampusPress specific tools for your browser. You can
also import your posts or comments from other blogs to your site.

10) Settings: The Settings tool is the main area to set preferences or properties for your site. Click
on General, and type in a name of your site in Site Title field.

4. Change the site’s theme.

a. Click the ‘Appearance’ button on the left menu, click on Themes to view the available
themes. To preview the theme, simply click on theme thumbnail; to use the theme, click on
the upper right corner of the preview window where it says “Activate ‘whatever theme you
are viewing”.

b. Click the Coraline 1.2 by Automattic and activate this theme.

Themes vary according to their color schemes, layout, etc. Note that only the Rice
University themes and WordPress MU (multi-user or multi-site) default user are supported
by Rice IT, so you may be on your own if something goes wrong with a different theme.

c. Some themes allow you to customize the header image. If your theme does, you should
see “Header” in the sidebar under "Appearance." Click on this link. You can then upload
an image from your hard drive. You'll need to crop the image to fit the wide and thin
(banner-style) dimensions of your header, which you can do via a web interface.

You can upload a custom header image to be shown at the to

Themes able to crop the image.
Widgets Images of exactly 990 x 180 pixels will be used as-is.
Menus Choose an image from your computer:
Background

grou I Browse... ) Upload
Header D

d. Alist of themes that support a customized image header can be found at
http://wprocks.com/wordpress-tips/list-of-themes-that-support-custom-image-header/

e. You can also customize the background color or image of particular themes. Try this with
Rice 2010. Under the Appearance menu, choose background. You can upload an image or
use “Select a color” to choose a color from the color wheel.

f.  Note: CampusPress offers over 250 themes. Only vetted themes are added to the
selection set. To submit a theme, email helpdesk.rice.edu and the system administrators
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can forward your code to CampusPress for review. If you are using the external
WordPress.com platform, their themes directory offers over 1000 themes for download at
http://wordpress.org/extend/themes/. Alternatively, you can purchase themes from

companies such as WooThemes and Elegant Themes. To use some of the
externalWordpress themes, you will need to find a WordPress host

(http://wordpress.org/hosting/) and have some basic technical knowledge
http://codex.wordpress.org/Using_ Themes

5. Create some pages.

CampusPress differentiates between posts and pages. Blog posts are organized chronologically
and appear in the main part of your home page by default, while pages are static content and are
typically arrayed either at the top of your page and/or on a sidebar (depending on the theme).

1.

2
3.
4

Click the ‘Pages’ button on the left menu of the dashboard.

Click the ‘Add New’ button on the ‘Pages’ sub-menu.
Enter a title for your main page, such as ‘CV and Bio’ and enter some text for the page.
Under Page Attributes > Order field, enter a number that will be used for putting this page
into its proper order. | recommend using O for the fist page, but increments of 10 for each
other page, so that it will be easy to re-sort or to put new pages into place later.

Page Attributes
Parent

(no parent) L]
Template

Default Template LJ
Order

0

5. Give your page a pithy title, and use the Word-like interface to compose your page. You
can create bulleted lists, use bold or italics, create new paragraphs, etc. If you wish to turn
something into a link, highlight that phrase and click on the link (chain) icon.

07 Add Media @&

B I

6.

we = = 66 — = =
You can also insert an image or media
into your pages. Just click on

07 Add Media .
, then you can either

choose files from your computer to
upload or insert from URL or Embed
Code. Or you can choose images

uploaded in your Media Library as well.

Last updated on 9/29/2015

Insert Media
Create Gallery

Set Featured Image

Insert from URL

Insert Embed Code

Visual Text
== K A
e

Set Featured Image

Upload Files | Media Library



7. You can "Preview" your page to see what it will look like. Your page will not be publicly
available until you click "Publish."

8. Once you’re satisfied with your page, click the ‘Publish’ button on the right of the page.

9. Go ahead and create pages for things like Research, Teaching, and Publications. You can re-
edit pages easily later, once you’ve played around and decided on an information
architecture.

6. Create a child page

Making “child” pages (subpages) is useful because you may not want all your pages to show in the
main page navigation of your CampusPress theme. In most themes, only “main” pages (pages that
don’t have a “parent”) show up in the main page navigation. In the CampusPress platform, child
pages show up in a popup menu that appears when you roll over the main page link. Lets make
Publications as the child page of Research page.

a. Open the page “Publications” in Edit or Quick Edit mode.

b. On Page Attributes on the right, click on Parent drop down menu, choose

“Research” as parent page, click on Preview Change, if satisfied, click on Publish.

7. Add some sidebar widgets.

"A Widget is a fancy word for tools or content that you can add, arrange, and remove from the
sidebars of your blog. Widgets make it easy to customize the content of your blog sidebar — the
part of your blog to the left, right or sometimes top or bottom of your main content"
(http://en.support.wordpress.com/widgets/). Some widgets automatically come with your theme.

a. From the ‘Appearance’ sub-menu on the left side of the control panel, click ‘Widgets’.

b. To add any widgets, simply drag from Available Widgets area and drop in Primary Widget
Area on the right side of your dashboard

c. Iftheyaren’tin that order, drag widget and drop it to your desired location.

d. Click on disclosure triangle to reveal more options under widgets. For example, drag
‘Archives’ widget and drop to right primary widget area. Click the disclosure triangle and
then enter ‘News Archives’ as a title. Select ‘Display as a drop down,” and then click ‘Save’
button.

Archives

Title:
News Archives|

(™ Display as dropdown
("] Show post counts

Delete | Close
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8. Create some links.

Create a sidebar that lists your favorite links, such as your department; class web pages, favorite
blogs, etc.

Click the ‘Links” button on the left menu of the dashboard.

Click the ‘Add New’ link on the ‘Links’ sub-menu.

Enter the title for your link (e.g. “Physics Department”).

Enter the URL for your link (e.g. http://yourdepartment.rice.edu).

Click the ‘Add Link’ button on the right side of the page.

Repeat adding links for every site or document you want to link to directly.

If you uploaded your CV as a PDF in your media library, you can find a direct link to it by
clicking the ‘Media’ button on the left menu of the dashboard, clicking the ‘Edit’ link under
the document, and copying the File URL.

File URL http://dmc.blogs.rice.eduffiles/2011/10/Using-the-DocuMate-Scanner.pdf

™ +0 oo oo

h. In order for Links to showLupon Jyour website, you need to add Links widget to your site.
Please refer Add some sidebar widgets on page 7.

9. Upload some media.

You may want to make files such as a PDF of your CV, photos, a recording, or other media
available on your web site. To do so:

Click the ‘Media’ button on the left menu of the control panel.

Click the ‘Add New’ link on the ‘Media’ sub-menu.

Under Upload New Media, browse on your computer to the files you’d like to upload.
Note that you can select multiple files at once—they’ll all be uploaded.

Note that although the maximum file size for a single upload is 50MB, Rice’s CampusPress
platform provides each blogs.rice.edu site with a 10GB total quota, including your media
library. A single video can use

up a lot of that space, so try to

be selective and make sure
your images are well-
compressed for the web.

f. For each file you’ve uploaded,
click ‘Edit’ and assign titles, Title Using the DocuMate Scanner
captions, and descriptions.
Note that every uploaded file
has been assigned with an Desoripiion How to use DocuMate Scanner 162
unique URL. If you want to link
the file on any page, this is the
place you can find and copy
the URL.

P oo oo

File name: Using-the-DocuMate-Scanner.pdf
dl File type: application/pdf

Upload date: October 5, 2011

Caption DocuMate162

File URL http://dme.blogs.rice.eduffiles/2011/10/Using-the-DocuMate-Scanner.pdf
Location of the uploaded file.

Last updated on 9/29/2015 1 O



g. Tolink a media file from Media Library to any page, you need to copy the File URL from
Media Library, then go back to your page, highlight the text you want to make link, then

&P

click on insert link icon
test the link.

, copy the URL, click on Add Link. You can Preview Changes to

‘@/Tips:

» As an alternative to CampusPress media library, you can use Rice’s online personal (2GB for
undergrads and 5GB for faculty and staff) storage space to upload your media files, then
link the files to your CampusPress pages or posts. For more information, visit IT website at
http://it.rice.edu/storageoptions/
or https://docs.rice.edu/confluence/x/LoDLAg.

» Be sure to upload well-compressed images to your media library to save space. If you have
many images to upload, then upload them to Flicker, Google images, or other image
hosting site before you embed them into your website.

» Uploading a short video to your media library is not recommended, because video files
generally take a lot of space. Please consider to set up an external YouTube account and
upload your videos to YouTube (remember Rice Gmail accounts cannot add videos to
YouTube). A web URL will be generated by YouTube for each of your video clips. You can
then copy the link and paste to your site.

» If you want to embed the video in your website, click on Share > Embed, then copy and
paste the embed code to your pages in HTML editing mode.

\1, Download + Add to < Share eee More

Embed
<iframe width="1280" height="720" src="https.//www.youtube.com/embed/

10. Create some posts and categories.

a. To create a new post, click on Posts on left navigation tools of your dashboard and click on
Add New. Use word-like interface to compose your content.

b. You can allow your readers to leave comments on your posts under Discussion by simply
checking the box next to Allow Comments.

a. You might want to create different categories to organize your posts. To do so, click on
Categories under Posts

b. Name the category and decide whether you want the category as a parent category, or a
subcategory of an existing category.
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c. Once you create a new category, you can add a new post to any categories by checking the

checkbox, click on Preview, then Publish your post.

11.Create custom menu

The Appearance Menus Screen enables a user to

create custom navigation menu in place of a
theme’s default menu.
* To create a new custom menu, click the

Edit Menus Manage Locations

Edit your menu below, or create a new menu.

"create a new menu" link, give the menu a name, and click Pages
Create Menu button. Note: If the current theme does not
support menus, the message, "The current theme does not

Most Recent  View All  Search

natively support menus, but you can use the “Custom Menu” oo s
widget to add any menus you create here to the theme’s o
sidebar." will display informing you that widgets can be used to -
put custom menus in a sidebar. OV and Bio
* After a menu is created, then detail items can be added to the S A To Mo

menu. Choose items like custom links, pages, and categories,

from the left column to add to the menu.

* After items have been added to a menu, drag and drop to put
them in the order you want. You can also click each item to

Links

Categories

Format

reveal additional configuration options. You can also drag a menu item a little to the right
to make it a submenu, to create menus with hierarchy. You'll see when the position of the
drop target shifts over to portray the nested placement. When you have finished building
your custom menu, make sure you click the Save Menu button.

Menu Structure

Drag each item into the order you prefer. Click the arrow on the right of the

CV and Bio

Teaching

Research

Publications

Gallery

News

Contact Us
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* Once you have saved the menu, be sure to click on Manage Locations tab on the top to
change your primary navigation to your custom menu. Then click on Save Changes.

Edit Menus Manage Locations

Your theme supports 1 menu. Select which menu you would like to use.

Theme Location Assigned Menu

Primary Navigation §Menu1 j Edit | Use new menu

— Select a Menu —

| Save Changes Menul |

12.Create Image Gallery (http://wordpress.tv/2013/03/12/how-to-create-an-image-
gallery-in-wordpress/ )

Image galleries are a great way to share groups of pictures on your WordPress site. The Create
Gallery feature of the WordPress media uploader allows you to add a simple image gallery to
pages or posts on your site.

* Place your cursor: A gallery can go anywhere on a page or post - by itself on a blank page, or
above, below, or in the midst of text. Start by placing your cursor where you want the gallery
to appear - if it's in between blocks of text, like in the photo example below, consider adding a
return and placing your cursor on a new line so there's space above and below.

* Click the Add Media button: Once you've placed your cursor where you
want your image gallery to appear, click on the Add Media button
(located left above the editing window) to launch the media uploader — =
interface. In the resulting popup window, select the 'Create a Gallery' option from the list of
actions on the left.

Oy Add Media

* Add and/or Select the Images You Want to Include: You can add or select the images you want
to include in your image gallery by choosing from either of the following options in the center
of the media uploader window:

o Upload Files: Upload the images you want to use from your computer by dragging
them into the upload area. You can add more than one image, and they will be
automatically grouped together as an image gallery.

o Media Library: Select from previously uploaded images in the media library by clicking
on the ones you wish to add to the gallery. You will see a checkbox next to your
selections.

o Note: You can create an image gallery using any combination of new images and
previously uploaded images simply by switching back and forth between the Upload
Files and Media Library tabs.

o Asyou upload and/or select images, you will see your selection confirmed on the Insert
Media screen by check boxes at the top corner of each thumbnail. Also, a row of
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thumbnails appears at the bottom of the window to help you keep track of all the
images you’ve selected. When you are happy with your selection, click the Create a
new gallery button.

Edit Your Gallery: On the Edit Gallery page, you can do the following things before
inserting the gallery you have created into your page or post:

Rearrange your images: Drag and Drop image thumbnails to rearrange the
order of images in your gallery.

Reverse Order: Reverses the order of the images in your gallery.

Add image descriptions: Add descriptions to your images (optional) which
appear as image captions below each thumbnail in the gallery.

Remove images: Hover over a thumbnail and click on the "X" to remove any of
the images you previously selected.

Add more images: Click on the "Add to Gallery" link in the left hand sidebar and
add or select the images you want to include in your image gallery by choosing
from either "Upload Files" or "Media Library" tabs.

Cancel Gallery: Click on the "Cancel Gallery" link from the actions on the left to
exit the Edit Gallery page and cancel your image gallery.

o Check Gallery Settings: Gallery Settings are available in a pane on the right to control
the following:

o Editing Existing Galleries: Within the visual editor, the image
gallery is displayed as a series of thumbnail images. When you
click any area of the image gallery, icon buttons appear top of
the area. At any time, you can edit the images or settings of

13. Add some plugins

Links To: Controls whether the gallery thumbnails (on the published page/post)
link to the image attachment page or directly to the source image file itself.
Columns: Set the number of columns you would like to have in your gallery.
Random Order: Enables your gallery to display your image thumbnails in a
random order each time they are viewed on the site.
Size: Changes each image size in gallery. Available
options are Thumbnail, Media, Large and Full Size.

your gallery by clicking on the Edit button. You can remove the image gallery at any
time by clicking on the Remove button.

* Contact Form: The Contact Form plugin is designed to add a straightforward contact form to
your blog which allows visitors to your blog to send you an email. Once you have activated the
Contact Form plugin in Plugins > All you need to: go to Settings -> Contact Form; Add your email address;
Click Update Options; Go to Pages > Add New; Create a Contact page and add the contact
form code to the page. For more information, visit http://help.edublogs.org/contact-form-

plugin/

* Social Bookmarking: The AddThis Social Share adds Social Share button to every post and
page, so readers can easily share your content on their social networks. You can also add the
Social Share widget to your blog sidebar. Once you have activated the AddThis Social Share
plugin in Plugins > All, go to Settings > AddThis Share to choose the look of your social share
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buttons and where they are displayed. In the basic settings select which icons you want to
appear above and below the posts. On the advanced settings page select which pages you
want the icons to appear. You would normally show AddThis on homepage and pages. To
configure your sidebar widget and add social media links to your sidebar, just drag the new
AddThis Share widget into your desired sidebar in Appearance -> Widgets. For more
information, visit http://help.edublogs.org/addthis-social-bookmarking-plugin/

* Google Map: The Google Maps plugin allows you to easily embed, customize, and use Google
maps in posts, pages and your sidebar. You can also display local images and let your site
visitors get directions in seconds. Once you have activated the Google Maps plugin in Plugins >
All, go to Posts > Add New (or Pages > Add New), write your post, place your cursor where
you want the map to be inserted and then click on the Google Maps icon. Enter the location
you want to display and then click Add. To add more location(s), just add the address(es) and
then click Add. Alternatively you can add a location(s) by zooming in on your map, click
on Drop Marker to add a Marker to your Map and then drag/drop it to the desired location.
Give your map a name. Now zoom in on your place marker(s) so your readers have the best
map view of your location. You can click on Map Options to set your Map preferences. Click
OK once you have chosen your map options. Click Save changes to this map in the Add Map
window. Click Insert this map. The Add Map window will close and the map will be added to
your visual editor using Google maps shortcode as shown below. When you view your
published post you will see your Google Map embedded in your post. For more information,
visit http://help.edublogs.org/working-with-the-maps-plugin/

Tips: To apply a certain plugin, just activate it fist, then refer to Plugin Help for instruction on how to use
the plugin. In general, the plugins are easy to use and the instruction is very straightforward.

14.Turn your blog into a web site.
So far, your primary site page has been a blog page. Now, we’re going to make your primary site
page a content page.

1. Click the ‘Settings’ button on the left menu of the control panel.

2. Out of the box, WordPress adds the tagline "Just another WordPress blog,” which you will
see in Settings > General. Replace this with something unique to your site, e.g. a five-word
description of your research or the name of your endowed chair.

Click the ‘Save Changes’ button.

If you would like to use a static page as your home page (what appears when people first
visit your site), create and publish the page, then on the left of your dashboard, go to
Settings>Reading.

On Reading Settings page, select ‘Front page displays: “A static page.”’

Select ‘Front page: “Home.””

Select ‘Posts page: “News.””

Click ‘Save Changes.’

Do you want people to be able to add comments to your pages or posts? You can modify
your comments settings by going to Settings > Discussion. If you don't want to allow
comments, uncheck "Allow people to post comments on the article." See

Hw

Lo N W

Last updated on 9/29/2015 1 5



http://codex.wordpress.org/Settings_Discussion_SubPanel for an explanation of the

settings.
10. You can delete your site under Tools, or Export your entire site as XML file and import it
into different WordPress friendly platform.

Congratulations, you now have a web site! Fill in the content and let people know about the site.
If you do decide to delete your site, go to Tools > Delete Site

Resources
1. CampusPress support page: http://about.blogs.rice.edu/
2. Edublogs user guide: http://help.edublogs.org/user-guide/
3. Official Word Press Support: https://en.support.wordpress.com/
4. Embed Content: http://help.edublogs.org/user-guide/embedding-media/
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