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INTRODUCTION

This guide is intended for those interested in tracking the movement of small 
organisms, such as worms, hydra, etc. without prior experience with motion 
tracking and/or who do not have specialized software and equipment. 

Both the software and equipment used in this guide are available from the 
DMC. Adobe After Effects is the software used to perform 2D motion 
tracking in this guide. A separate guide on Matlab’s motion tracker may help 
those familiar with Matlab.

The results of Adobe After Effect’s tracker will provide you with data on the 
frame-by-frame pixel coordinates of the tracked subject(s). The tracker works 
with single and multiple subjects. While this guide is focused on tracking 
small organisms (and hydra will be used as an example), the same process 
can be used to track other objects.

This guide is divided into three main sections: footage collection, preparing 
footage, and motion tracking.
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CLICK ON EACH HEADING TO 
JUMP TO THAT SECTION



FOOTAGE COLLECTION TIPS

MOST IMPORTANT TIP 💡
Make sure the camera is 100% steady during recording

• Most tracking software have issues when the footage is not taken from a 
stationary camera. Even tiny movements, such as a gradual shifting of the 
camera, will make tracking more difficult.

• Tighten all the screws on the tripod.
• Avoid unnecessary movement near the camera.

CHOOSING A BACKGROUND
Whenever possible, choose a solid colored background that 
contrasts with your subject. For example, if you are recording dark 
colored worms, choose a solid white background.

KEEP LIGHTING CONSTANT
• Make sure your subjects are well-lit. 

• Dim lighting = high ISO = grainy images
• Make sure the lighting does not change over time.

4

FOR SLOW MOVING ORGANISMS:
Use a Canon DSLR for incremental photos

• 0.2 fps can be taken using EOS Utility, connected to a PC
• 1 fps requires downloading Magic Lantern
• Manually focus

FOR FAST MOVING ORGANISMS:
Use a camcorder for video (30 fps)

• Manually focus



Footage of hydra (10 mm 
organisms) were collected 
using the following setup:

SAMPLE SETUP
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Petri Dish

Heating Plate

10 in.
LED Light Strip 
(wraps around dish)

Side View

Top View

Heating Plate

Petri 
Dish

LED Light Strip 
(wraps around dish)

• Canon EOS Rebel T3i DSLR with 
EFS 18-55mm f/3.5-5.6 IS lens

Resolution: 5184 × 3456
ƒ/7.1
Exposure1/160
ISO 1600

• Flexible LED light strip
• Standard tripod

The hydra are contained in the petri 
dish. The camera’s distance from 
the petri dish is the minimum 
focusing distance for the particular 
lens used.



PREPARING FOOTAGE IN
ADOBE AFTER EFFECTS
I. User Interface
II. Importing
III. Create a Composition
IV. Scaling & Rotating
V. Adjust Curves
VI. Optional: Linear Color Key
VII. Optional: Difference Matte
VIII. Linear Color Key vs. Difference Matte
IX. Finalizing Footage
X. Optional: Time Stretching
XI. Optional: Exporting



USER INTERFACE

Timeline

Composition Panel

Other panels will expand when clicked

Project 
Panel

Toolbar

Toolbar Shortcuts:
• Selection Tool (V)
• Hand Tool (H)
• Zoom Tool (Z)
• Rotation Tool (W)
• Pen Tool (G)
• Type Tool (Cmd+T)
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IMPORTING

Organize Your Files
Create a folder for your footage. Make sure you create this folder in 
a location that will be stored if you are using a shared computer. 

New Project
1. Open After Effects (AE)
2. Create a New Project
3. Click “File” > “Save As…” at the top of the window

• Name your project
• Choose the folder you created earlier with your footage
• Click the “Save” button

Import
1. Double-click in the Project Panel to open the file browser*
2. Select your video file OR an image sequence

• To import an image sequence, click “Options” and make sure the 
“Importer JPEG Sequence” box or “PNG Sequence” box is checked

• Only the first image needs to be selected

*Alternatively, you can drag-and-drop media directly into the Project Panel
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Note: “Imported” files are 
referenced by the AE 
project file. The files are 
NOT copied to your project 
location. If you change the 
location of the original files, 
AE cannot load the video 
properly.



CREATE A COMPOSITION
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1. Select the footage you imported
2. Right-click
3. Choose “New Comp from Selection”

New composition 

Contents of the Composition 
are loaded into the Timeline

Move the Playhead to scrub 
through the video

Contents of the 
Composition



SCALING & ROTATING

To center footage and fit to frame
• Use the “Selection Tool” (V) to click on the footage in the 

Composition Panel. A selection box should appear around the 
footage.

• Click on the corner of the selection box and drag to scale the 
image. Hold Shift to scale proportionally.

To rotate footage
• Use the “Rotation Tool” (W)
• Click and drag in the Composition Panel to rotate the image

Alternatively, directly change the values under the 
“Transform” property of the layer in the Timeline
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ADJUST CURVES
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1. Make sure your 
footage is selected

2. Click on the Effects Panel > 
Color Correction > Curves

3. Click and drag the curves on the graph to adjust the tonal range. 
You can also change the channel you want to adjust. 

GOAL: Add more tonal contrast to your footage to make your 
subject(s) stand out from the background. 



Optional: Linear Color Key effect
If your footage does not have a solid background, the Linear Color 
Key effect can help improve the tracker’s accuracy by subtracting 
out the background based on a selected background color.
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OPTIONAL:

LINEAR COLOR KEY

Without Linear Color Key With Linear Color Key

Use the eyedropper tool to select a 
color from the background

Adjust these settings 
until background is 
sufficiently removed



OPTIONAL:

DIFFERENCE MATTE
Optional: Difference Matte effect
If your footage does not have a solid background, a difference 
matte can help improve the accuracy of the tracker. 

What is the Difference Matte effect?
“The Difference Matte effect creates transparency by comparing a source layer with a 
difference layer, and then keying out pixels in the source layer that match both the position 
and color in the difference layer. Typically, it’s used to key out a static background 
behind a moving object, which is then placed on a different background.”   - AE User Guide

Two ways to create a source layer:
A. During the footage collection stage, capture one frame/image 

without any organisms in the frame (ex: empty petri dish)
• IMPORTANT: this image must be taken in the exact same 

position as the rest of your footage. Everything in the frame must 
be the same except for the removal of the organisms.

B. Create an artificial source layer in Photoshop (see next page)
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Without Difference Matte With Difference Matte

https://helpx.adobe.com/after-effects/using/keying-effects.html#difference_matte_effect


Creating a source layer in Photoshop:
1. Open Adobe Photoshop
2. File > Scripts > Load files into Stack…
3. Click “Browse…” and choose 5-10 images from your footage

• Get a variety from the beginning, middle, and end of your recording
• If you are using a video file instead of  an image sequence, export 

some images first (see external link)

4. Check the boxes for “Attempt to Automatically Align Source 
Images” and “Create Smart Object”

5. Click OK

6. Layer > Smart Objects > Stack Mode > Median
7. If any hydra remain, use the “Spot Healing Brush Tool”
8. To export the image, File > Export > Quick Export as PNG
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OPTIONAL:

DIFFERENCE MATTE cont.

https://photoshoptrainingchannel.com/remove-tourists-stack-mode/


Import the source layer
1. Import the source layer you created into the Project Panel
2. Click and drag the source layer into the Timeline, underneath 

your footage (in the example below, my source layer is called “demo 2.png”)

Apply the Difference Matte in AE
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2. Click on the Effects Panel 
> Keying > Difference Matte

1. Make sure your footage is selected

3. The effect will appear here

OPTIONAL:

DIFFERENCE MATTE cont.

4. Press the eye icon to hide the source layer from view

5. Choose your source layer

6. Adjust settings until background is 
sufficiently removed

IMPORTANT: make sure any “curves” 
adjustment is after the difference matte effect



LINEAR COLOR KEY vs.

DIFFERENCE MATTE
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Transparent hydra shows up 
with the Difference Matte, but 
not with the Linear Color key

Linear Color Key:
• Clean results
• Easy to use
• Only works when 

background color 
contrasts with 
the subject

Difference Matte:
• Results vary 

depending on 
the quality of the 
source layer

• Difficult to use
• Can work 

regardless of 
background

Use either the Difference Matte or Linear Color Key as desired, but 
NOT both.



FINALIZING FOOTAGE
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Right-click on your footage 
layer in the Timeline. Choose 
“Pre-compose…”

Note: This new composition is contained within your original composition

ü Now the footage is ready for motion tracking

Choose

Click OK

Name



Optional: Time Stretching
Used for speeding up footage. If your subjects move infrequently or 
slowly, time stretching might help reduce processing time during the 
motion tracking. For Matlab, it may also improve accuracy.
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OPTIONAL:

TIME STRETCHING

Make sure you are in 
your original, or “main” 
composition. Not the 
one you just created on 
page 17. Right-click on the layer name of the 

composition you made on page 17
Choose Time > Time Stretch

Change the “Stretch Factor” to change 
the duration. Think of the value as a 
percentage of original duration. 

100 = 100% (same speed)
20 = 20% (faster than original)

You are dropping frames to speed up



Optional: Exporting
You can export your adjusted footage to be used in other software. 
If you are motion tracking in AE, this step is unnecessary. 
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OPTIONAL:

EXPORTING

With your main composition 
selected, choose “Composition” > 
“Add to Render Queue” 

The Timeline will now change into the Render Queue Panel.
Change render settings as needed and choose an output folder.
• You can choose to export as a video file in various formats or as image sequences
Click “Render” to create an exported file. 



MOTION TRACKING IN
ADOBE AFTER EFFECTS
I. Setting Up
II. Adding Track Points
III. Adjusting the Tracker
IV. Running the Tracker
V. Saving Data
VI. Troubleshooting/Tips



SETTING UP
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1
4

2

3

1. Make sure your main composition is selected, not the finalized footage 
you made on pg. 17

2. In the Timeline, also check that the main composition tab is selected

3. Finally, make sure that the layer with the finalized footage is selected

4. Click on the “Tracker” panel 



ADDING TRACK POINTS
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1
2

1. Click “Track Motion”

2. A “Track Point” box will appear on the composition panel. Click & drag 
the box over the subject you want to track. 
• When you drag, the box will be temporarily magnified for greater accuracy
• The inner box tells AE what to look for during the tracking
• The outer box is the search region that AE uses to look for your subject
• The + in the middle of box is the “Attach Point.” This is the point whose 

coordinates are recorded. Place the Attach Point over an identifiable part of 
your subject (i.e. a part of the subject that contrasts with the background)

• Click and drag the 4 points around the box to resize/reshape the boxes. Both 
the inner and outer box can be resized.

Troubleshooting
• If the boxes are not moving together, you may be moving the attach point
• If you can’t see any track point boxes, make sure you are in the correct 

composition and click on the “Tracker” layer in the Timeline 



ADJUSTING THE TRACKER
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To add more track points, click 
the     button on the Tracker Panel 
and choose “New Track Point”
Repeat the same steps as before 
to position all the new track points

Press the “Options…” button to 
bring up the options window

Channel: Select RGB if the tracked feature is a distinct color. Select Luminance if the 
tracked feature has a different brightness than the surrounding. Select Saturation if the 
tracked feature has a high concentration of color, surrounded by variations of the same 
color (such as a bright red scarf against a brick wall).
Enhance Before Match: Temporarily blurs or sharpens an image to improve tracking.
Track Fields: Temporarily doubles the frame rate of the composition and interpolates 
each field to a full frame to track motion in both fields of interlaced video.
Adapt Feature On Every Frame: Causes After Effects to adapt the tracked feature for 
each frame. The image data that is searched for within the search region is the image data 
that was within the feature region in the previous frame, rather than the image data that 
was in the feature region at the beginning of analysis.
If Confidence Is Below: Specifies the action to perform when the Confidence property 
value is below the percentage value that you specify.
• Select Continue Tracking to ignore the Confidence value.
• Select Extrapolate Motion to estimate the position of the feature region. Attach-point 

keyframes aren’t created for low-confidence frames, and attach-point keyframes for the 
low-confidence frames from previous tracks are deleted.

• Select Adapt Feature to use the original tracked feature until the confidence level falls 
below the specified threshold. At that point, After Effects adapts the tracked feature to 
be the contents of the feature region in the frame preceding the one that has low 
confidence and continues tracking.



Press the Analyze buttons on the Tracker Panel to begin the tracking process.
Analyze 1 Frame Backward: Analyze the current frame by moving back one frame
Analyze Backward: Analyze from the current-time indicator backward to the beginning
Analyze Forward: Analyze from the current-time indicator to the end
Analyze 1 Frame Forward: Analyze the current frame by advancing to the next frame

When the analysis is in progress, the Analyze Forward button changes to a 
Stop button that you can press to stop the analysis at any point.

In this example below, the analysis ran from frame 63 to 101.

RUNNING THE TRACKER
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Keyframes record the 
position of the track points

❗If the track points drift away from the subject during the analysis, you can 
stop the analysis and manually reposition the track point(s) and then 
press the analyze button again. You can move the playhead to find the 
specific frame from which you must restart the analysis. (i.e. no need to 
restart from the beginning)

A trail of track points will be 
displayed as small yellow 
boxes after the analysis.



SAVING DATA

To save the results of the tracker, go into the Timeline and select 
Motion Trackers > Tracker # > Track Point # > Feature Center

Press Cmd+C to copy the position data of the track point. Cmd+V
to paste the data in any document, such as an excel spreadsheet:

Repeat for multiple track points as needed.
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The data from the Feature 
Center is the pixel coordinates 
of the Attach Point



TIPS/TROUBLESHOOTING

How big should my Search Region (outer box) be?
The bigger the search region, the longer the processing time.
Also, if the search region covers many subjects that look identical, the tracker 
might accidently jump from one subject to another.

How do I track the changes in size of my subject?
• If you are tracking a single subject, you can check both the “Position” and 

“Scale” boxes on the Tracker Panel. A second track point with a line 
connected to the first track point will appear. Position both track points on 
the same subject (ex: one on the head and one on the tail). Now the 
distance between the two track points will be recorded.

• Alternatively, with multiple subjects, only keep the “Position” box checked 
and place two track points on each subject. After you copy the Feature 
Center data onto a spreadsheet, you can calculate the distances between 
two related track points yourself. Take note of which track point is which!

Can I leave the Analysis running unattended?
It is recommended that you stop the analysis once every 50 frames to check 
that all the points are still following your subjects. That way, you can reposition 
them as soon as possible.

How do I reduce the tracking time? 
• You can export the video first (see pg. 19) and then import it back, create 

a new composition with the new video, and then add the track points. 
• Reduce the size of the search region and the feature region (both boxes)

The track points do not follow my subjects very well
• Try adjusting the options in the Tracker panel
• Increase the size of the Search Region (the outer box)
• Or re-collect footage at a higher fps
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