• Setting Up IntelliJ IDEA for Creating and Testing Scala Projects

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

IMPORTANT Warning About sbt Version 1.3.0

There is currently a bug in sbt (Scala Build Tool) version 1.3.0 that interacts poorly with the official Scala plugin for IntelliJ (see SCL-16208). You should use sbt version 1.2.8 (the previous stable version) until a new version is released. The bug has been patched in sbt, so we expect version 1.3.1 and onward will work correctly once available. 

A patched version of the IntelliJ Scala plugin has been released. If you're using the newest version this should no longer be an issue.

Other Options

Using sbt Directly

...